Welcome to AutoForumz.com!
FAQFAQ    SearchSearch      ProfileProfile    Private MessagesPrivate Messages   Log inLog in

03 Eclipse: Won't Start

 
   car problems (Home) -> Mitsubishi RSS
Next:  Remote Start for 2006 Accord  
Author Message
Edd Dicker

External


Since: Dec 09, 2006
Posts: 12



(Msg. 1) Posted: Wed Dec 19, 2007 2:39 pm
Post subject: 03 Eclipse: Won't Start
Archived from groups: alt>autos>mitsubishi (more info?)

Seems the bad weather in NJ (ice and below freezing temps) have done my
poor little ride in.

First I thought it was the battery but alas, even with a Jump, only
worked once.

6 Cyl GT Manual

Symptoms:
Turn the Ign. Key, dashboard lights up and just click/click/click.
Seems to be power related since the lights will come on, go 1/2 off and
then kinda sputter.
When I try again, all lights on dash go dead and nothing, not even a
click.

When I just turn on headlights or parking lights, seems to be a weird
low hum from just forward under hood of driver side where fuse box is.

Any help would be appreciated.

Thanks!
Edd

 >> Stay informed about: 03 Eclipse: Won't Start 
Back to top
Login to vote
Andrea Zambelli

External


Since: Oct 02, 2007
Posts: 6



(Msg. 2) Posted: Wed Dec 19, 2007 6:55 pm
Post subject: Re: 03 Eclipse: Won't Start [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

"Edd Dicker" ha scritto nel messaggio

> Seems the bad weather in NJ (ice and below freezing temps) have done my
> poor little ride in.
>
> First I thought it was the battery but alas, even with a Jump, only
> worked once.
>
> 6 Cyl GT Manual
>
> Symptoms:
> Turn the Ign. Key, dashboard lights up and just click/click/click.
> Seems to be power related since the lights will come on, go 1/2 off and
> then kinda sputter.
> When I try again, all lights on dash go dead and nothing, not even a
> click.

ECU/ECM fried and/or ISC gone.
check them and substitute if necessary.

andrea

 >> Stay informed about: 03 Eclipse: Won't Start 
Back to top
Login to vote
NickySantoro

External


Since: Sep 07, 2005
Posts: 160



(Msg. 3) Posted: Wed Dec 19, 2007 8:26 pm
Post subject: Re: 03 Eclipse: Won't Start [Login to view extended thread Info.]
Imported from groups: per prev. post (more info?)

Back to top
Login to vote
Nirodac

External


Since: Sep 09, 2007
Posts: 2



(Msg. 4) Posted: Fri Dec 21, 2007 7:42 am
Post subject: Re: 03 Eclipse: Won't Start [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

NickySantoro wrote in


> On Wed, 19 Dec 2007 09:39:22 -0500, Edd Dicker wrote:
>
>>Seems the bad weather in NJ (ice and below freezing temps) have done my
>>poor little ride in.
>>
>>First I thought it was the battery but alas, even with a Jump, only
>>worked once.
>>
>>6 Cyl GT Manual
>>
>>Symptoms:
>>Turn the Ign. Key, dashboard lights up and just click/click/click.
>>Seems to be power related since the lights will come on, go 1/2 off and
>>then kinda sputter.
>>When I try again, all lights on dash go dead and nothing, not even a
>>click.
>>
>>When I just turn on headlights or parking lights, seems to be a weird
>>low hum from just forward under hood of driver side where fuse box is.
>>
>>Any help would be appreciated.
>>
>>Thanks!
>>Edd
> How old is the battery? Have you had it tested? They can be good one
> day and as dead as Julius Caesar the next. I've also seen them with
> internal shorts that precluded even a jump.
> FWIW
> YMMV
>

Yup, had the same thing with in my Ford. Battery was good one day, then
drove to the mall. After 20 minutes in the mall I couldn't even crank it
over. Surprisingly even a jump from a large truck battery didn't start
it. Turns out the max output voltage of the battery was 9.xx volts. I
had a shorted cell.
Didn't figurer that out until after I had the vehicle towed home and I
changed out the starter motor.

Check the battery voltage. Your battery is near (if not already at) it's
end of life, and cold weather doesn't help.
 >> Stay informed about: 03 Eclipse: Won't Start 
Back to top
Login to vote
G. R. Woodring

External


Since: Mar 11, 2006
Posts: 9



(Msg. 5) Posted: Sat Dec 22, 2007 4:48 am
Post subject: Re: 03 Eclipse: Won't Start [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

On 12/19/2007 9:39 AM, Edd Dicker wrote:
> Seems the bad weather in NJ (ice and below freezing temps) have done my
> poor little ride in.
>
> First I thought it was the battery but alas, even with a Jump, only
> worked once.
>
> 6 Cyl GT Manual
>
> Symptoms:
> Turn the Ign. Key, dashboard lights up and just click/click/click.
> Seems to be power related since the lights will come on, go 1/2 off and
> then kinda sputter.
> When I try again, all lights on dash go dead and nothing, not even a
> click.
>
> When I just turn on headlights or parking lights, seems to be a weird
> low hum from just forward under hood of driver side where fuse box is.
>
> Any help would be appreciated.
>
> Thanks!
> Edd

A faulty or discharged battery seems most likely here, although bad battery
terminal connections can cause similar effects.

*Important* Before doing anything, remove the battery caps (if possible) and
look at the electrolyte. If _any_ cells are frozen, don't charge the battery or
crank the engine. Hydrogen gas can build up under the ice and a short could
cause an explosion.

If the battery is old it's easiest to just replace it. Otherwise have it fully
charged and tested to make your decision. Batteries get old and fail but it
would be a good idea to have the electrical system checked to be sure some other
problem didn't kill it.


--
G. R. Woodring
 >> Stay informed about: 03 Eclipse: Won't Start 
Back to top
Login to vote
Edd Dicker

External


Since: Dec 09, 2006
Posts: 12



(Msg. 6) Posted: Sat Dec 22, 2007 9:28 pm
Post subject: Re: 03 Eclipse: Won't Start [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

Thank you all who wrote.
It was a dead, shorted battery.

Seems with a new, fresh battery all my issues are gone.

Thanks to you all!

Happy Holidays!

Edd


In article ,
"G. R. Woodring" wrote:

> On 12/19/2007 9:39 AM, Edd Dicker wrote:
> > Seems the bad weather in NJ (ice and below freezing temps) have done my
> > poor little ride in.
> >
> > First I thought it was the battery but alas, even with a Jump, only
> > worked once.
> >
> > 6 Cyl GT Manual
> >
> > Symptoms:
> > Turn the Ign. Key, dashboard lights up and just click/click/click.
> > Seems to be power related since the lights will come on, go 1/2 off and
> > then kinda sputter.
> > When I try again, all lights on dash go dead and nothing, not even a
> > click.
> >
> > When I just turn on headlights or parking lights, seems to be a weird
> > low hum from just forward under hood of driver side where fuse box is.
> >
> > Any help would be appreciated.
> >
> > Thanks!
> > Edd
>
> A faulty or discharged battery seems most likely here, although bad battery
> terminal connections can cause similar effects.
>
> *Important* Before doing anything, remove the battery caps (if possible) and
> look at the electrolyte. If _any_ cells are frozen, don't charge the battery
> or
> crank the engine. Hydrogen gas can build up under the ice and a short could
> cause an explosion.
>
> If the battery is old it's easiest to just replace it. Otherwise have it
> fully
> charged and tested to make your decision. Batteries get old and fail but it
> would be a good idea to have the electrical system checked to be sure some
> other
> problem didn't kill it.
 >> Stay informed about: 03 Eclipse: Won't Start 
Back to top
Login to vote
Display posts from previous:   
Related Topics:
97 Eclipse won't start - I changed the oil in my eclipse and then drove it down the road. When i got back i decided that i would check the air filter before i went in. I have a K&N air filter, when i put it back on I tried to start my car and all it will do is crank. It w...

94 Eclipse won't start-no spark - Hi all, This is my sons car and I'm pulling out what little hair I have left trying to figure this out. He is going back into the Army in the next week so we need to get it fixed. I read similar posts here but none are exactly what my problem and..

1997 Red Eclipse f/s - RS. runs great. good tires, new brakes, new brk rotors, looks great. no major body or paint damage. asking 3500 or b/o see more details on my site: www.fortynorth.4t.com

2003 eclipse rs - i have parts for 2003 eclipse rs 75 miles on car

1990 mit eclipse - my 1990 mit eclipse GSX. the dash light went on while i was going 85 mph in the rain. the light was check engine/battery/and brake. then during the at a stop, the light britens up then as i accellerate it dims down again. what is the problem?
   car problems (Home) -> Mitsubishi All times are: Pacific Time (US & Canada)
Page 1 of 1

 
You can post new topics in this forum
You can reply to topics in this forum
You can edit your posts in this forum
You can delete your posts in this forum
You can vote in polls in this forum



[ Contact us | Terms of Service/Privacy Policy ]